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Overview
Overview

This guide contains information on how to install and configure Worksoft Certify from start to finish. Before you 
begin to install the product, review the system requirements and installation prerequisites. Go to Worksoft 
Help Portal to see the system requirements. You will install and configure Certify Enterprise in the following 
order:

Verify System 
Requirements

Perform Installation 
Prerequisites

Acquire and 
Install Worksoft 

License Key

Create Certify 
Database

Install Certify Configure Certify

Optional
Install and 

Configure Worksoft 
Certify Services
Worksoft Certify Installation Guide 7

http://docs.worksoft.com/
http://docs.worksoft.com/


Worksoft Certify Enterprise Package
Worksoft Certify Enterprise Package

The Worksoft Certify Enterprise package consists of the following components:

Worksoft Certify Deployment
The diagram below illustrates Worksoft Certify deployment.

Component Description

Worksoft Certify Site Prep.zip This zip file contains the following:
• Database Scripts directory- Contains the utility and scripts that 

you will use to create and update your Certify database.
• Worksoft Certify Installation Guide

CertifySetup.exe Executable that installs Worksoft Certify client.

CertifySetup.msi If you are logging in as a local administrator on the machine, you 
are able to install Worksoft Certify client with this file.

CertifyBaseSetup.exe Executable that upgrades only the Certify base. It will not 
upgrade and install any interfaces.

InterfaceVersions.txt Document that lists the interface versions within the package.

Certify Services directory Contains the CertifyServices.exe executable that installs Worksoft 
Certify API so that you will be able to utilize Worksoft Certify for 
Automator’s mode and Certify Results API.

Documents directory Contains a link to the Worksoft Certify Installation Guide.
8 Worksoft Certify Installation Guide



Worksoft Certify Services
Worksoft Certify Services

Worksoft Certify Services consists of the following features:
 Worksoft Certify for Automators

Worksoft Certify for Automators works on a service layer that accelerates processes for remote users.
 Worksoft Certify Results API

Worksoft Certify Results API allows you to view Certify results and generate reports without having 
Worksoft Certify installed.

To use these features, you will need to install Worksoft Certify Services on an application server. For more 
information, see Chapter 9 “Preparing Your System for Worksoft Certify Services”.

Preparing Your System

Before installing and configuring Worksoft Certify, perform the following tasks in the order listed below:
1. Verify that the recommended system requirements are met on each computer where the Certify client will 

run. The Certify product has both minimum and recommended system requirements for the Worksoft 
Certify client, database server, and license server. Go to the Worksoft Help Portal to view the system 
requirements.

2. Obtain a license file from the Worksoft Customer Support. For information on how to install your license 
file, see the Setting Up Your Licensing section.

3. Set up a database server. For more information, see“Creating a Certify Database” on page 11.
4. Install all required third-party interface applications on Worksoft Certify clients. Go to Worksoft Help Portal 

to see the system requirements.
5. If you decide to distribute the Certify client on individual desktops, select a method for distributing the 

Worksoft Certify installation files to your users. For more information, see Chapter Chapter 4, “Distributing 
Installation Files,” on page 28.

6. If you are working with the SAP interface, see Chapter 2 “Configuring Your SAP Environment”
If you plan to use Worksoft Certify Services, see Chapter 9 “Preparing Your System for Worksoft Certify 
Services” Additional system requirements are needed. For more information, see the Worksoft Help 
Portal.
If you are using Certify with a Citrix XenApp® system, see Chapter Chapter 6, “Installing Worksoft Certify 
Client into a Citrix Environment,” on page 34, and the Worksoft Help Portal for system requirements 
information.
If you are using Certify with a Windows® Terminal Server, see Chapter Chapter 7, “Installing Worksoft 
Certify Client in a Windows Terminal Server Environment,” on page 41, and the Worksoft Help Portal for 
system requirements information.
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Setting Up Your Licensing
Setting Up Your Licensing

With Worksoft Certify v12 and later releases, you will use Worksoft Portal or Worksoft Management 
Studio for licensing. Worksoft Portal is replacing Management Studio as the administration tool for Worksoft 
products that manages licenses, users, and database settings.
If you are a new customer, Worksoft Customer Support will provide you with Worksoft licenses.
Go to the Worksoft Help Portal at docs.worksoft.com for Worksoft Portal information about the following:
 System requirements
 Installation and configuration
 Uploading license files
If you are using Worksoft Execution Suite or on-premise Worksoft Analyze, you already have Management 
Studio installed. You can register your licenses with that Management Studio instance.

Installing a Temporary Standalone License Key

A license key is needed to activate Worksoft Certify. Before you are able to acquire a permanent license key, 
you may be given a temporary standalone license key. This temporary key allows you to run Worksoft Certify 
without a centralized license server. You will need to install this license on each Certify client until you receive 
your permanent license key.
If you do not have a license server, the license file WorksoftLic.xml must be installed in the following 
directory: 
C:\Program Files (x86)\Worksoft\Certify\Client
To install a temporary standalone license key:
1 On the Certify Client, copy and paste the license key file provided by Worksoft to the following directory:

C:\Program Files (x86)\Worksoft\Certify\Client

2 When you configure Worksoft Certify, select the No License Server option in the License section. For 
more information, see “Configuring Worksoft Certify Client” on page 24.

3 Click Save to save the configuration file.
10 Worksoft Certify Installation Guide
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Preparing the Database
Preparing the Database

Overview

To use Certify, you will need to create, connect to, and configure a SQL Server database. Use the information 
below to help guide you through the process of creating the Certify database.
Before you begin, determine the following:
 What type of database are you using?
 Who is going to create the database?
 Does the database need to be set up and configured?
 Where will the database reside? Is it on a local computer or a remote server? 
 What is the database name? 
 How do you connect to the database?
If your company is required to maintain results for an extended period, you need to create a second database 
for archiving results. The recommended name for this archive database is CertifyArchive. Your company's 
database administrator will need to assist you with creation of both the Certify and CertifyArchive databases. 
Your CertifyArchive database must have the same permissions and the same user access as your Certify 
database.

Creating a Certify Database

Use the Certify Configuration tool to specify the type of database you are using with Certify and how to 
connect to that database. The Configuration tool requests the following database information:
 Location of the database (e.g., server or computer name)
 Name of the database
 User ID for accessing the database server
 Password for accessing the database server
A configuration file, which contains the specifics on how to connect to the database, is created by the Certify 
Configuration tool for distribution with each Certify client.
Before creating the Certify database, Microsoft SQL Server should be installed on the computer or server 
where the database will reside. Read the system requirements in the Worksoft Help Portal to verify that you 
have a supported version of SQL Server. The SQL Server software is not provided with Certify. Download the 
software from Microsoft's web site.
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Populating Your Certify Database
 To create a Certify database with the SQL Server Management Studio:

1 Install and set up SQL Server on the computer or server by using the documentation provided by 
Microsoft.

2 Launch SQL Server Management Studio from Start > All Programs > Microsoft SQL Server. 
The SQL Server Login dialog box appears.

3 Connect to the server where the database you are creating for Certify will reside.
4 Right-click Databases and select New Database. 

The New Database dialog box appears.
5 Type a name for the Certify database in the Name field.
6 Leave the owner for the database as (Default).

Note: If you are not allowed to use "sa" as the User ID and the default password, then a new Certify 
user ID and password must be created. We recommend "CertifyUser" as the user ID. This user 
ID and password must have full database owner rights to the database, including the right to 
create tables and views, read, update, and delete. Essentially, this user must have the same 
rights as the "sa" user ID while the database is initially being created. After the database is 
created, the new "CertifyUser" rights may be scaled back to database owner rights only. 

7 Click OK. 
The database is created.

8 Close the SQL Server Management Studio. 

Populating Your Certify Database

After you have created your database, you will now need to populate your Certify database. If you purchased 
Worksoft’s SAP MasterContent database, then you will populate your database through the SQL Server 
Management tool.
If you did not purchase the SAP MasterContent database, then you will use the Apply.exe utility and the 
database scripts that are located in the Database Scripts directory within the Worksoft Certify Site Prep.zip file. 
Your database administrator may want to review each of the scripts before populating the database. For more 
information, see Populating Your Database with the Apply.exe Tool.

Populating Your Database with the SAP MasterContent Database

If you are using Worksoft’s SAP MasterContent database, then you will need to create your Certify database 
from the MasterContent backup database.

 To create a Certify database from the MasterContent backup database:

1 Launch SQL Server Management Studio from Start > All Programs > Microsoft SQL Server. 
The SQL Server Login dialog box appears.

2 Connect to the server where the database you are creating for Certify will reside.
3 Right-click Databases and select Restore Database.

The Restore Database dialog box appears.
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Populating Your Database with the Apply.exe Tool
4 In the Destination for Restore section of the General page, type in the new database name.
5 In the Source for Restore section, select MasterContent.bak. Depending on the software version, the 

exact file name will vary. You may need to use the Browse button to select your database.
6 Click OK.

The database is created. If there are patches to be applied, refer to the Readme file included with the 
patch to upgrade your database.

Populating Your Database with the Apply.exe Tool

If you are creating a database on a remote server, SQL Server must be installed on that server.

 To create a Certify database:

1 Locate the Apply.exe utility within your Certify Enterprise distribution:
...\Worksoft Certify Site Prep\Site Prep\Database Scripts\CertifyDatabase

2 Double-click Apply.exe.
The Apply utility opens.

3 In the text fields, type in the following database connection information:
• Database server name
• Database name

4 If you will use the Windows authentication security option, select the option. Go to Step 6.
5 If you selected SQL database authentication, type the user name and password in the text fields to 

access the database server.
6 Click Start.

The Apply utility begins to create your new database.
If there are patches to be applied, refer to the Readme file included with the patch to upgrade your 
Certify database.

Transaction Log Settings

To ensure the transaction logs for the Certify database do not expand out of control causing you to experience 
performance issues, perform the following:
 Set your maintenance plans to back up the transaction logs periodically. The transaction log will grow 

when the database is in full or bulk-logged recovery models.
 Optionally, change the recovery model of the Certify database to Simple Recovery mode so that you are 

able to maintain your transaction log growth and have less maintenance. Databases that have a Full 
Recovery mode will have substantially larger transaction logs. 
If your company’s IT policy does not allow the database to run in Simple Recovery Mode and you need to 
use the Full Recovery mode, then you will need to verify that you have enough disk space for the log files 
on your database server. For small organizations, you need at least 20 GB of free space. For large global 
organizations, you will need at least 50 GB of free space.
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Next Step
Next Step

If you are working with the SAP interface, then you will need to configure your SAP environment before you 
begin to configure your Certify environment. See Chapter 2 “Configuring Your SAP Environment” for more 
information.
If you are not working with the SAP interface, then you are ready to install Worksoft Certify. For more 
information, see Chapter 3 “Installing and Configuring Worksoft Certify”
If you are upgrading your Certify system, see Chapter 5 “Upgrading Your Worksoft Certify Client Version”
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Chapter 2 Configuring Your SAP Environment
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Overview
Overview

In order for Worksoft Certify to work with your SAP environment, you will need to configure the following:
 SAP GUI
 SAP Application Server
This chapter shows you how to configure your environment.

Note: Before you begin configuring your environment, verify that your SAP environment does not 
have the SAP Signature theme selected. Worksoft Certify only supports the Enjoy and Classic 
themes.

Configuring the SAP GUI

The SAP GUI needs to be configured to support the script recording and playback feature of the Certify SAP 
Learn utility.

 To configure the SAP GUI to support script recording and playback:

1 Log on to SAP.

2 From the SAP GUI interface, click the Customizing of Local Layout  button from the 
SAP toolbar.
The Settings menu appears.

3 Click Options.
The Options dialog box appears.

4 Click the Scripting tab.
The Scripting tab appears.

5 Under the User Settings field, select the Enable Scripting check box.
6 Remove the check marks in the remaining check boxes. 
7 Click Apply.
8 Click OK.

The Options dialog box closes.
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Enabling SAP GUI High Speed Connection
 To set your modal properties:

1 Log on to SAP.
2 From the SAP GUI toolbar, select Help > Settings.

The Personal Settings dialog box appears.
3 Click the F4 Help tab.
4 In the Display section, select Dialog (modal).
5 Click the Save button.

Enabling SAP GUI High Speed Connection

The SAP GUI Logon Pad needs to be configured to use the high speed connection for your SAP system that you 
will be using with Certify.

 To configure the SAP GUI to use the high speed connection:

1 Open the SAP Logon Pad.
2 Select the SAP system that you will be using with Certify.
3 If you are using SAP GUI for Windows v7.1, then click the Change Item button.

If you are using SAP GUI for Windows v7.2, then right-click on the SAP system and select Properties.
If you do not see either option on the SAP Logon Pad, then you do not have the appropriate permissions 
to change this setting. You will need your SAP System Logon administrator's help to complete this setup.
The System Properties dialog box appears.

4 Click the Network tab.
5 In the Network Settings section, select the High Speed Connection (LAN) option.
6 Click OK.

Configuring the SAP Application Server

Once you have configured the SAP GUI interface to support script recording and playback, the SAP Application 
Server(s) must be configured to support scripting. Worksoft Certify interacts with the SAP interface through 
user scripting. Scripting must be enabled in the active SAP application server in order to use Certify on the 
server. 
You must enable scripting in the permanent SAP configuration for the SAP application server in order to ensure 
that scripting support remains enabled when the server is restarted. Transaction rz11 is used to enable 
scripting in the active SAP application server. Transaction rz10 is used to permanently enable scripting in the 
SAP application server configuration. This section presents both procedures.
You must have administrator rights to the SAP Application Server to make these changes.
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Configuring the SAP Application Server
 To enable scripting with transaction rz11:

1 From the SAP GUI interface, type rz11 in the Command field of the SAP toolbar. 
2 Press <Enter>.

The Maintain Profile Parameter screen appears.

3 In the Param Name field, type the following: sapgui/user_scripting.
4 Click Display.

The Display Profile Parameter Attributes screen appears.

5 Click the Change Value button.
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Configuring the SAP Application Server
The Change Parameter Value screen appears.

6 In the New Value field, type TRUE.
7 Click the Save button.

8 Change these additional parameters:

Your SAP system is now able to interact with Certify.

 To enable scripting with transaction rz10:

1 From the SAP GUI interface, type rz10 in the Command field of the SAP toolbar. 
2 Press <Enter>.

The Edit Profiles screen appears.

Parameter Value

sapgui/user_scripting_disable_recording FALSE

sapgui/user_scripting_force_notification FALSE

sapgui/user_scripting_set_readonly FALSE
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Next Step
3 In the Profile field, select the name of the profile you want to update.
4 In the Edit Profile section, select the Extended Maintenance option.
5 Click Change.

The Maintain Profile screen appears.

6 In the Parameter Name column, select the sapgui/user_scripting parameter. If it does not exist, 
create the parameter.

7 In the Parameter Value column, the parameter value should be set to TRUE. If it is not set to TRUE, edit 
the value by double-clicking on the parameter or pressing <F2> to open the parameter’s properties.

8 After you have completed your edits, a change confirmation message appears, click Yes.
9 If you created the parameter or changed the value, restart the instance to update the new value.

Your SAP system is now able to interact with Certify.

Next Step

You are now ready to install Worksoft Certify. For more information, see Chapter 3 “Installing and Configuring 
Worksoft Certify”.
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Installing Worksoft Certify Client
Installing Worksoft Certify Client

Worksoft Certify client and all supported interfaces are installed with the CertifySetup.exe file. You must 
have full administrator rights on the computer in which you plan to install Certify.
If you are using Certify with a Citrix XenApp system, see Chapter 6 “Installing Worksoft Certify Client into a 
Citrix Environment”
If you are using Certify with a Windows® Terminal Server, see Chapter 7 “Installing Worksoft Certify Client in a 
Windows Terminal Server Environment”
After you have installed Worksoft Certify, you will need to configure the product. For more information, see 
“Configuring Worksoft Certify Client” on page 24.

 To install the Worksoft Certify client:

1 If needed, temporarily disable anti-virus software and close all open applications on your computer.
2 Right-click the CertifySetup.exe file and select Run as Administrator.

If you are logging in as a local administrator on the machine, double-click CertifySetup.msi.
The Worksoft Certify Install Wizard opens.

3 Click Next.
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Installing Worksoft Certify Client
The Destination Folder page appears.

4 If you want to accept the default directory for your installation files, click Next.
If you do not want to accept the default directory for the installation files, select a different installation 
directory and click Next.
The Ready to Install page appears.

5 Click Next to begin the installation.
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Configuring Worksoft Certify Client
The installation completes, and the Setup Complete page appears.

6 If you do not want to open Certify, cancel the Run Worksoft Certify Now option.
7 Click Finish.

You are now ready to create your Certify test environment.

Configuring Worksoft Certify Client

After you have installed Worksoft Certify, you will need to configure the product with the Certify Configuration 
tool. With this utility, you will set the following:
 Mode
 Database settings
 Licensing
The Certify Configuration tool creates a file named Worksoft.Certify.exe.config. You can find this file in your 
C:\Program Files (x86)\Worksoft\Certify\Client directory. The configuration settings control 
access to the Certify system, its database, the license server, and web servers. Current settings are created at 
the time of installation.

Automator's Mode

You can select to use Certify Classic mode or Automator’s mode that is designed for Certify users who work on 
a remote machine. The Automator’s mode works on a service layer that accelerates process execution for 
remote users. To use the Certify for Automator's feature, you will need to install Worksoft Certify Services on 
an application server.
The Worksoft Certify Services installation package is included in the Worksoft Certify distribution package. For 
more information, see Chapter 9 “Preparing Your System for Worksoft Certify Services”
This section provides instructions for both Automator's mode and Classic mode.
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Automator's Mode
 To configure Worksoft Certify client in Automator’s Mode:

1 Open Worksoft Certify by double-clicking on the Certify desktop icon.
2 From the Certify menu, select Configure > Certify > Database and Licensing.

The Certify Configuration tool appears.

3 Select the Automator’s Mode option.
4 In the Database Server Name field, type in a server name.
5 In the Database Name field, type in a database name. 

If you would like to select a database from the drop-down list, you will need to set up your security 
authentication first. Go to Steps 6 and 7.

6 Select which Security option that you will use:
• Use Windows Authentication
• Use SQL Server Authentication

7 If you selected SQL database authentication, type the user name and password in the text fields to 
access the database server.

8 In the Service Layer URL field, type in the URL address for the web server that is hosting Worksoft 
Certify Services.
Example: http://servername/certifyapi

9 Click the Validate Service URL button to test your connection.
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Automator's Mode
10 In the License Model section, select one of the following options and enter the required information:
• Worksoft License File

If you do not have a license server, the license file WorksoftLic.xml must be installed in the 
following directory: C:\Program Files (x86)\Worksoft\Certify\Client

• Worksoft License Server
Type the Management Studio URL and tenant information. Use Default as your tenant name unless 
you already have tenants created.

11 Click Validate License to test the connection.
If for some reason the test fails, you will need to troubleshoot the license server connection.

12 Click OK.
A message appears stating that you need to restart Certify.

13 Click Yes to restart Certify with these saved configuration changes.

 To configure Worksoft Certify client in Classic Mode:

1 Open Worksoft Certify by double-clicking on the Certify desktop icon.
2 From the Certify menu, select Configure > Certify > Database and Licensing.

The Certify Configuration tool appears.

3 Select the Classic Mode option.
4 In the Database Server Name field, type in a server name.
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Next Step
5 In the Database Name field, type in a database name. 
If you would like to select a database from the drop-down list, you will need to set up your security 
authentication first. Go to Steps 6 and 7.

6 Select which Security option that you will use:
• Use Windows Authentication
• Use SQL Server Authentication

7 If you selected SQL database authentication, type the user name and password in the text fields to 
access the database server.

8 Click the Validate Database Connection button to test your connection.
If for some reason the test fails, you will need to troubleshoot the database connection.

9 In the License Model section, select one of the following options and enter the required information:
• Worksoft License File

If you do not have a license server, the license file WorksoftLic.xml must be installed in the 
following directory: C:\Program Files (x86)\Worksoft\Certify\Client

• Worksoft License Server
Type the Management Studio URL and tenant information. Use Default as your tenant name unless 
you already have tenants created.

10 Click Validate License to test the connection.
If for some reason the test fails, you will need to troubleshoot the license server connection.

11 Click OK.
A message appears stating that you need to restart Certify.

12 Click Yes to restart Certify with these saved configuration changes.

Next Step

You are now ready to distribute installation files to all Certify users. For more information, see Chapter 4 
“Distributing Installation Files” You will need to include the Worksoft.Certify.exe.config file that you created in 
the installation directory.
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Distributing Worksoft Certify Installation Files
Distributing Worksoft Certify Installation Files

If you are installing Worksoft Certify on multiple workstations, create a directory on a shared drive to distribute 
the following files:
 Worksoft Certify installer - CertifySetup.exe or CertifySetup.msi
 Worksoft Certify configuration file - Worksoft.Certify.exe.config
These files must be located in the same directory in order for Certify to install correctly.

 To distribute the Certify client installation files to users:

1 Create a CertifyInstall directory on a shared drive and provide access to all Certify users.
2 From the Worksoft Certify package, copy CertifySetup.exe or CertifySetup.msi and paste it into the 

CertifyInstall directory.
3 Copy the Worksoft.Certify.exe.config file from the single workstation where you installed Certify and 

paste into the CertifyInstall directory. 
This file is located in the following directory:
C:\Program Files (x86)\Worksoft\Certify\Client

4 Notify the Certify users of the following:
• Name and location of the CertifyInstall directory
• Instructions for installing Certify
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Testing the Worksoft Certify Upgrade Release
Testing the Worksoft Certify Upgrade Release

Before you install the Certify upgrade on your production server, you need to test and verify the upgrade 
release.

 To test and verify the upgrade:

1 Create a full backup of your production Certify database.
2 Create a new Certify test database in SQL Enterprise Manager and restore the Production Certify 

database backup into this new database. You will need to have Database Owner rights to the restored 
test database in order to complete this update.

3 If needed, temporarily disable anti-virus software and close all open applications on your computer.
4 Upgrade your Certify test database with the Multi-Version Upgrade utility. For more information, see 

Upgrading Your Worksoft Certify Version.
5 Before you install Certify, execute your critical Certify processes using this test database to verify that 

the test machine is set up correctly. Take note of the test results prior to the upgrade.
6 Right-click the CertifySetup.exe file and select Run as Administrator. For more information about 

installing and configuring Certify, see Chapter 3 “Installing and Configuring Worksoft Certify”.
If you are logging in as a local administrator on the machine, double-click CertifySetup.msi.

7 Open Certify and verify that the upgraded database contains all of your data, including variables, 
recordsets, layouts, processes, requirements, etc. 

8 Execute your critical Certify processes again to see if the results are still the same as before the 
upgrade. If you have a number of discrepancies, do not proceed with the upgrade and notify Worksoft 
Support. 

9 Once the tests are complete and you have verified the upgrade works, then you are ready to upgrade 
your production server. Before you upgrade on your production machine, all users must be logged out of 
the Certify production database.

Upgrading Your Worksoft Certify Version

The Worksoft Certify product has both minimum and recommended system requirements for your database 
server. Before installing Worksoft Certify, ensure that your server meets the requirements listed in the Worksoft 
Help Portal for the new version.

 To upgrade your Certify database:

If you have multiple Certify databases, Worksoft recommends upgrading all of your Certify databases, 
including the Certify results archival directory, to the same version.
1 Back up your current database.
2 Locate the Apply.exe utility within your Certify distribution:

...\Worksoft Certify Site Prep\Site Prep\Database Scripts\UpdateDatabase

3 Double-click Apply.exe.
The Apply utility opens.
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Upgrading Your Worksoft Certify Version
4 In the text fields, enter the following database connection information:
• Database server name
• Database name

5 If you will use the Windows authentication security option, select the option. Go to Step 7.
6 If you selected SQL database authentication, type the user name and password in the text fields to 

access the database server.
7 Click Start to begin updating your database.

Worksoft Certify v12.0.2112

If you have over 500,000 LogImageData rows in your database, you need to use the upgrade and migration 
executables in the UpdateDatabase - Post Upgrade Migration directory. For more information, see 
Appendix G “Compressing Images in Your Database.”

Upgrading Your Worksoft Certify Version
The Worksoft Certify product has both minimum and recommended system requirements. Before installing 
Worksoft Certify, ensure that your system meets the requirements listed in the Worksoft Help Portal for the 
new version.

 To upgrade your Worksoft Certify version:

1 Close Worksoft Certify and all browsers.
2 If needed, temporarily disable anti-virus software and close all open applications on your computer.
3 Right-click the CertifySetup.exe file and select Run as Administrator.

You do not need to uninstall previous versions of Certify because the installer for the new version will 
uninstall the older version.

4 After you have installed and configured Certify, you can update all Certify clients by distributing the 
installation files to all users. For more information, see Chapter 4 “Distributing Installation Files”.
If you have Worksoft Certify Services installed, you are able to update all Certify clients by using the 
Worksoft Certify Auto Update tool. For more information, see the Worksoft Help Portal.

Upgrading Worksoft Certify Services

Before installing Worksoft Certify Services, ensure that your system meets the requirements listed in the 
Worksoft Help Portal for the new version.

 To upgrade Worksoft Certify Services:

1 Close Worksoft Certify Services and all browsers.
2 If needed, temporarily disable anti-virus software and close all open applications on your computer.
3 Right-click the CertifyServices.exe file and select Run as administrator.

You do not need to uninstall previous versions of Certify Services because the installer for the new 
version will uninstall the older version.
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Upgrading Earlier Versions of Worksoft Certify Services
Upgrading Earlier Versions of Worksoft Certify Services

Worksoft Certify Services was introduced in version v11.0.1911, so if you have an earlier version of Certify for 
Automators and Certify Results API, you will need to complete these procedures.

 To upgrade Worksoft Certify for Automator’s:

1 Uninstall earlier version of Worksoft Certify for Automator’s.
2 Delete the Certify Web API directory from the old installation path:

C:\Program Files (x86)\Worksoft\Certify Web API

3 Install Worksoft Certify Services. For more information, see Chapter 9 “Preparing Your System for 
Worksoft Certify Services”

 To upgrade Worksoft Certify Results API:

1 Uninstall earlier version of Worksoft Certify Results API.
The App_Data directory will not be deleted from the old installation path:
C:\Program Files (x86)\Worksoft\Worksoft Certify Results API

Do NOT delete this directory because it contains Worksoft Management Studio connection information 
and generated tokens that you will paste into the new installation directory.

2 Install Worksoft Certify Services. For more information, see Chapter 9 “Preparing Your System for 
Worksoft Certify Services”.

3 From the old installation path, copy the contents of the App_Data directory and paste the contents into 
the new installation path:
C:\Program Files (x86)\Worksoft\Certify Services\Certify Web API\App_Data
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Overview
Overview

This chapter provides you with the following information needed if you are using Worksoft Certify client with 
Citrix XenApp®:
 Configuring your Citrix server
 Installing Worksoft Certify client on a Citrix server
 Accessing Worksoft Certify client through the Citrix client
 Troubleshooting

Configuring Your Citrix Server

When using Worksoft Certify in a Citrix XenApp environment, all applications that Certify needs to access must 
be shared in the same Citrix session ID with Certify. Worksoft recommends using Citrix in the Published 
Desktop mode with Certify so that no additional configuration will be needed.
You will need to install the following applications on the same Citrix server:
 Worksoft Certify client
 Any application under test, such as an SAP GUI application
 Any third-party tool, such as SmartBear® Software TestExecute™ or Microfocus Application Lifecycle 

Management®
If you are unable to run Citrix in a Published Desktop mode, then you will need to enable sharing in the Citrix 
session. Certify and all of the required applications will need to be installed on the same Citrix server to ensure 
that all of the applications are shared on the same Citrix session ID.

System Requirements

If you are using Citrix XenApp, you will need additional system requirements. Requirements are listed in the 
Worksoft Help Portal, and these recommendations are based on field usage of Worksoft products for a typical 
IT organization. Before you purchase your server hardware, consult with your Citrix administrator.

Installing Worksoft Certify Client to a Citrix Server

Before you install Worksoft Certify, you will need to first create a Certify database. For more information, see 
“Preparing the Database” on page 11.
When you install Worksoft Certify client to a Citrix machine, the machine must be in the Install mode.

 To set your Citrix server into the Install mode:

1 Log on to the Citrix server as a local administrator
2 Open a Command Prompt window as an Administrator.
3 To put your Citrix server into the Install mode, type change user /install in the Command Prompt 

window.
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Installing Worksoft Certify Client to a Citrix Server
4 Press <Enter>.
Your server is now in the Install mode.

5 Minimize the Command Prompt window, but leave it open to change the server back to Execute mode 
after installing Worksoft Certify.

 To install Worksoft Certify client on a Citrix server:

1 If needed, temporarily disable anti-virus software and close all open applications on your computer.
2 Right-click the CertifySetup.exe file and select Run as Administrator.

The Worksoft Certify Install Wizard opens.

3 Click Next.
36 Worksoft Certify Installation Guide



Installing Worksoft Certify Client to a Citrix Server
The Destination Folder page appears.

4 If you want to accept the default directory for your installation files, click Next.
If you do not want to accept the default directory for the installation files, click the Change button to 
select a different installation directory for the Certify client, and then click Next.
The Completing the Maintenance Wizard page appears.

5 Click Next to begin the installation.
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Installing Worksoft Certify Client to a Citrix Server
The installation completes, and the Setup Complete page appears.

6 If there are no patches to be installed and you want to open Certify, select the Run Worksoft Certify 
Now option.
If there are patches to be installed, do not select the Run Worksoft Certify Now option. Refer to the 
Readme file included with the patch to upgrade the Certify client.

7 Click Finish.
You are now ready to create your Certify test environment.

 To set your Citrix server into the Execute mode:

1 Restore the Command Prompt window.
2 To put your Citrix server into the Execute mode, type change user /execute in the Command 

Prompt window.
3 Press <Enter>.

Your server is now in the Execute mode.
4 Close the Command Prompt window.
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Accessing Worksoft Certify Through the Citrix Client

Worksoft Certify client, the application under test, and any third-party applications must be published on the 
Citrix server as an application. You do not need to publish Certify Learn utilities that can be launched from the 
Certify menu. To access the Certify command line functionality in Citrix, export the batch file and then publish 
the batch file as a Citrix published application.
Each application that you publish must use an explicit user. Worksoft does not recommend using an 
anonymous user because customizations and user preferences will be lost after the user logs out.
Depending on the configuration of Citrix, Certify can be accessed through the Citrix client by one of two ways:
 Logging on to a published desktop
 Using Certify as a published application

Logging on to a Published Desktop

If you choose to access Certify by logging on to a published desktop, no additional configuration is needed. 
During a remote desktop session, Certify will interact with any other applications that are running in the same 
unique session. 

Using Certify as a Published Application

As a published application, Certify will not be accessed through a remote desktop session, and it will only 
interact with other published applications launched in the same client’s unique session. For example, if the 
client runs both Certify and Microsoft® Internet Explorer® during a unique session, Certify will be able to 
interact with the Internet Explorer window. 
Certify running as a published application will not be able to interact with any local application that is run on 
the client machine.
Like most Windows applications, the Certify client needs write access to the Application data directory for the 
user. Under recommended settings from Citrix, the Application data directory should be writable and 
maintained across the Citrix farm for each Citrix user using the Roaming profile. For more information on the 
best practices for setting up profile types, see http://support.citrix.com/article/CTX110351.
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Troubleshooting
Troubleshooting

This section provides solutions to issues that you may encounter when using Citrix XenApp with Certify.

Issue: After installing the Certify client, Certify will not start and reports Unhandled Exception errors when 
trying to connect to the database server.

Cause: Your Citrix server may not be able to reach the Domain Name Server (DNS) for your system to 
resolve server names into IP addresses.

Solution: Verify that the Citrix server can successfully access your DNS to resolve server names. If you can 
not access your DNS, then change the names of the license server and the database server in the 
Worksoft.Certify.exe.config file to the actual IP addresses. After you have made these changes, you 
will need to restart Certify.

Issue: Screen captures in Certify reports are displaying as “black boxes” with screen fields and other 
objects displayed as white outlines on the screen.

Cause: The Citrix server’s desktop display color depth is less than 16-bit.

Solution: The minimum supported resolution for Certify screen captures in Citrix is 16-bit. 

Issue: If you are running the SAP interface and you receive the following error, “wsTest.Main: wsSAP.dll 
cannot be loaded”.

Cause: Worksoft Certify was installed by a user without the required administrator permission, or Worksoft 
Certify was not installed through the Windows Control panel.

Solution: Log on as the server administrator and reinstall Certify using the Windows Control panel.

Issue: Certify SAP and HTML Learn utilities not working and an error message appears.

Cause: You do not have permissions to open the utility on the Citrix machine.

Solution: Open permissions on your Citrix machine for the following directory: 
C:\Program Files\Worksoft. 
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Chapter 7 Installing Worksoft Certify Client in a 
Windows Terminal Server Environment
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Configuring Your Terminal Server
Configuring Your Terminal Server

This chapter provides you with the following information needed if you are using Worksoft Certify client with a 
Windows Terminal Server:
 Configuring your terminal server
 Installing Worksoft Certify client on a terminal server
Before you begin using your terminal server with Certify, the following applications must be installed on the 
same server:
 Worksoft Certify client
 Any application under test, such as an SAP GUI application
 Any third-party tool, such as SmartBear® Software TestExecute™

System Requirements

If you are using a Terminal Server, you will need additional system requirements. Requirements are listed in 
the Worksoft Help Portal, and these recommendations are based on field usage of Worksoft products for a 
typical IT organization. Before you purchase your server hardware, consult with your Terminal Server 
administrator.

Installing Worksoft Certify Client to Your Terminal Server

Before you install Worksoft Certify client, you will need to first create a Certify database. For more information, 
see “Preparing the Database” on page 11.
When you install Worksoft Certify client to a terminal server, the machine must be in the Install mode.

 To set your terminal server into the Install mode:

1 Log on to the terminal server as a local administrator
2 Open a Command Prompt window as an Administrator.
3 To put your terminal server into the Install mode, type change user /install in the Command 

Prompt window.
4 Press <Enter>.

Your server is now in the Install mode.
5 Minimize the Command Prompt window, but leave it open to change the server back to Execute mode 

after installing Worksoft Certify.
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Installing Worksoft Certify Client to Your Terminal Server
 To install Worksoft Certify client on a terminal server:

1 If needed, temporarily disable anti-virus software and close all open applications on your computer.
2 Right-click the CertifySetup.exe file and select Run as Administrator.

The Worksoft Certify Install Wizard opens.

3 Click Next.
The Destination Folder page appears.
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Installing Worksoft Certify Client to Your Terminal Server
4 If you want to accept the default directory for your installation files, click Next.
If you do not want to accept the default directory for the installation files, click the Change button to 
select a different installation directory for the Certify client, and then click Next.
The Completing the Maintenance Wizard page appears.

5 Click Next to begin the installation.
The installation completes, and the Setup Complete page appears.
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Installing Worksoft Certify Client to Your Terminal Server
6 If there are no patches to be installed and you want to open Certify, select the Run Worksoft Certify 
Now option.
If there are patches to be installed, do not select the Run Worksoft Certify Now option. Refer to the 
Readme file included with the patch to upgrade the Certify client.

7 Click Finish.
You are now ready to create your Certify test environment.

 To set your terminal server into the Execute mode:

1 Restore the Command Prompt window.
2 To put your terminal server into the Execute mode, type change user /execute in the Command 

Prompt window.
3 Press <Enter>.

Your server is now in the Execute mode.
4 Close the Command Prompt window.
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Database Maintenance
Database Maintenance

Worksoft provides database maintenance scripts to help improve Certify performance. These scripts allow 
you to:
 Archive results to a separate database
 Delete results
These database scripts are found in the following directory:
SitePrep\Database Scripts\Results Maintenance

Based on how Certify is being used, your database administrator will determine whether to delete your results 
or archive them on a separate database. Database maintenance should be performed by the database 
administrator. 
For information on using these database maintenance scripts, see the Tech Note - Managing Worksoft 
Certify Results.pdf file that is included in the DB Maintenance directory.
Other ways to help improve the database performance is to have adequate memory on the Certify database 
server and using a dedicated database server whenever possible.

Creating Additional Databases

After installing Certify, it may be necessary to create additional databases for use with Certify. Each time you 
create a database, you will need to have the following information:
 Database server
 Database name
 User ID and password for the database server 
For procedures on creating databases, see “Creating a Certify Database” on page 11.

Switching Databases

If you have more than one Certify database, you can switch databases in Certify.

 To switch databases

1 Log on to Certify.
2 In the menu, click Tools > Change Configuration.

The Configuration Tool appears.
3 In the Database Server Name text field, select a server from the drop-down list or type in a 

server name.
4 In the Database Name text field, select a database from the drop-down list or type in a 

database name.
5 Select which Security option that you will use:

• Windows Authentication
• SQL database Authentication

6 If you selected SQL database authentication, type the user name and password in the text fields to 
access the database server.
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Switching Databases
7 Click the Test Database Connection button to test the database connection.
A message appears stating the connection was successful.

8 Click Save.
A message appears stating that Certify must close down in order to complete this database change.

9 Click Yes to save changes and to close Certify.
Certify closes.

10 Log on to Certify.
Certify is now connected to the new database.
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Overview
Overview

This chapter contains information on how to install and configure Worksoft Certify Services which consists of 
the following services:
 Worksoft Certify for Automators
 Worksoft Certify Results API
Before you begin to install Worksoft Certify Services, you need to install Worksoft Certify and the needed 
system requirements. For more information, see the Worksoft Help Portal. The additional requirements for 
Worksoft Certify Services are also listed in the Portal.

Worksoft Certify for Automators

Worksoft Certify for Automators works on a service layer that accelerates processes for remote users. After you 
install Worksoft Certify Services, you will be able to select between two separate Certify modes in the Change 
Configuration tool:
 Automator’s mode
 Classic mode
You must select Automator’s mode in order to utilize the service layer.

Worksoft Certify Results API

Worksoft Certify Results API allows you to view Certify results and generate reports without having Worksoft 
Certify installed. Users can query a Certify database using RESTful API calls, and view result attributes, 
processes, and process attributes. Data is returned in JSON format for third-party reporting tools to display 
and provide calculations.

Worksoft Portal

Worksoft Certify and Certify Results API require the administration tool Worksoft Portal installed.
The Worksoft Portal register database settings, licenses, users, and integrations for Worksoft products. Certify 
leverages this information.
Go to the Worksoft Customer Portal to download these products. If you already have one of these tools 
installed, you can use that version.
For system requirements and installation guides, go to the Worksoft Help Portal. 
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Configuring Your Application Server
Configuring Your Application Server

In order to transform your application server into a web server to host the Worksoft Certify Services, 
Microsoft® Internet Information Services (IIS) must be installed and the Server Manager must be configured.
These procedures assume that you have not already configured your IIS. If you have already set up the Roles 
and Features, verify that the following Role Services on page 58 have been selected.
You need to first configure your server with HTTP, and then you can reconfigure the application server to use 
HTTPS.

Adding Roles and Features

The Server Manager allows you to add specific roles and features to your web server that are required for 
Worksoft products.

 To add roles and features to your web server:

1 From the Start menu, select Server Manager.
The Server Manager opens.

2 In the Navigation pane, select Dashboard.
3 In the Summary Tasks pane, select Add Roles and Features.
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Adding Roles and Features
The Add Roles and Features Wizard opens.

4 Click Next.
The Select Installation Type page opens.

5 Select the Role-based or feature-based Installation option.
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Adding Roles and Features
6 Click Next.
The Select Destination Server page opens.

7 Select a server.
8 Click Next.
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Adding Roles and Features
The Select Server Roles page opens.

9 From the Server Roles list, select the following roles:
• File Services
• Web Server (IIS)

10 Click Next.
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Adding Roles and Features
The Select Features page opens.

11 Select the following features:
• .NET Framework 4.8 Features and all of its child nodes
• WCF Services and all of its child nodes
• IIS Hostable Web Core and Media Foundation
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Adding Roles and Features
12 Verify that Message Queuing Services and Message Queuing Server are enabled.

13 Use the scroll bar to verify the Windows Process Activation Service is enabled with the following 
child nodes:
• Process Model
• Configuration APIs

14 Click Next.
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Configuring the Web Server Role (IIS)
Configuring the Web Server Role (IIS)

The Web Server Role (IIS) page opens if you have not already installed the web server. 
1 In the Navigation pane, click Role Services under Web Server Role (IIS).

The Select Role Services page opens.
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Configuring the Web Server Role (IIS)
2 In the Role Services list, use the scroll bar to select the following services.
If you have already set up the Roles and Features, verify that the following services have been selected.

3 Click Next.
The Confirm Installation Selections page appears.

4 Click Install to install the role services.

Node Child Nodes

Common HTTP Features Default Document

Directory Browsing

HTTP Errors

Static Content

WebDAV - Verify that this option is disabled. Worksoft’s 
RESTful Services will not work correctly if enabled.

Health and Diagnostics HTTP Logging

Request Monitor

Performance Static Content Compression

Dynamic Content Compression

Security Request Filtering

Basic Authentication

Application Development .NET Extensibility 4.8

Application Initialization

ASP

ASP.NET 4.8

CGI

ISAPI Extensions

ISAPI Filters

WebSocket Protocol

Management Tools IIS Management Console

IIS Management Scripts and Tools

Management Service
58 Worksoft Certify Installation Guide



Configuring Application/Json MIME Type Compression
Configuring Application/Json MIME Type Compression

After you have enabled Dynamic Content Compression within IIS, you need to verify HTTP Compression for the 
application/json MIME type. Certify Automator’s mode uses Dynamic Content Compression to improve 
performance, and HTTP compression must be enabled for the application/json MIME type. 
When the Dynamic Content Compression feature is enabled, it will overwrite any previous HTTP compression 
settings.

 To verify application/json MIME type compression:

1 Open IIS Manager.
2 In the left Navigation pane, click on your server. 
3 In the Management section, double-click the Configuration Editor.

The Configuration Editor opens.
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Configuring Application/Json MIME Type Compression
4 From the Section drop-down list, select system.webServer > httpCompression.

5 In the httpCompression section, click dynamicTypes.

6 Verify that application/json is listed in the dynamic compression mime types. If it is not listed, click 
the Add button in the Collection section to add it.
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Enabling IIS Services
7 After you completed your verification or addition, click the Close button
The Configuration Editor opens.

8 Click Apply to apply your changes.
9 Verify that dynamicTypes lists a count of six.
10 Close the editor.

Enabling IIS Services

You will now need to verify that several IIS services are enabled.

 To verify IIS services are enabled:

1 If the Server Manager is not open, select Administrative Tools > Server Manager from the 
Start menu.
The Server Manager opens.

2 In the Navigation pane, select IIS.
3 Scroll down to the Services section.
4 In the Services pane, verify that the following services are enabled and running:

• World Wide Web Publishing Service
• Web Management Service
• Application Host Helper Service
• Windows Process Activation Service

5 If any of these window services are not running, start the services.
To start a service, select the service from the list and click Start in the right menu. You can also start 
services by going to Administrative Tools > Services on your machine.
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Configuring HTTPS on Your Application Server
Configuring HTTPS on Your Application Server

To use HTTPS on your application server, leave the HTTP binding on default port 80. After you have 
reconfigured the application server to use HTTPS, the port now defaults to 443.
You need both ports open.
Complete the following tasks to configure HTTPS on your application server:
 Request an SSL Certificate from your IT department.
 Add the certificate to IIS.
 Add new binding to port 443.
 Verify your SSL Settings on your application server.

Installing Worksoft Certify Services

After you have configure your application server, you are now ready to install Worksoft Certify Services on your 
server. When you install Worksoft Certify Services, you have a choice to use a custom web site or the virtual 
default application that the installer creates.
If you want to use the virtual default web site, begin to install Worksoft Certify Services. When the installer 
runs, a virtual application called CertifyAPI is created with all of the correct settings.
If your company uses web sites requiring a Secure Socket Layer (SSL), you will need to create a custom web 
site before installing Worksoft Certify Services. For more information, see Configuring a Custom Web Site.

 To install Worksoft Certify Services:

1 Verify that you have met all system requirements for Worksoft Certify Services. For more information, 
see the Worksoft Help Portal.

2 In your software distribution directory, open the Certify Services directory.
3 Right-click the CertifyServices.exe file and select Run as administrator.
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Installing Worksoft Certify Services
The Worksoft Certify Services Install Wizard opens.

4 Click Next to begin the installation process.
The Select Features to Install page appears.
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Installing Worksoft Certify Services
5 Select the Certify Services features that you want to install.
By default, all three services will be installed.
If you do not want one of the services installed, click the arrow next to that feature and select Entire 
feature will be unavailable. 
AutoUpdates can not be removed. The AutoUpdates will be disabled unless you enable it. For more 
information, see the Worksoft Help Portal.

6 Click Next.
64 Worksoft Certify Installation Guide

http://docs.worksoft.com/Worksoft_Certify/Administration_Tasks/Certify_Administrator_Tasks.htm


Installing Worksoft Certify Services
The Destination Folder page appears.

7 If you want to accept the default directory for your installation files, click Next.
If you do not want to accept the default directory for the installation files, select a different installation 
directory and click Next.
The Worksoft Certify Results API Web Site Components page appears.
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Installing Worksoft Certify Services
8 If you want to use the virtual default application that the installer creates, keep the value Default Web 
Site.
If you created a custom web site, then select your site from the drop-down list.
Worksoft recommends that you manually create your web site through IIS so that port numbers are 
handled properly. If you choose to create a web site from this page by typing in a new name, the default 
port 80 is assigned to this web site.

9 Click Next.
The Worksoft Certify Web API for Automators Web Site page appears.

10 If you want to use the virtual default application that the installer creates, keep the value Default Web 
Site.
If you created a custom web site, then select your site from the drop-down list.
Worksoft recommends that you manually create your web site through IIS so that port numbers are 
handled properly. If you choose to create a web site from this page by typing in a new name, the default 
port 80 is assigned to this web site.

11 Click Next.
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Installing Worksoft Certify Services
The Worksoft Portal URL page appears.

12 If you do not have Worksoft Portal installed, click Next.
If you do have Worksoft Portal installed, enter the URL address and click Next.
The Ready to Install page appears.
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Accessing Worksoft Certify Results API
13 Click Install to begin the installation.
After the installation completes, the Installation Result page appears.

14 Click Finish.

Accessing Worksoft Certify Results API

The URL address for Worksoft Certify Results API can be accessed using:
http://<servername>/CertifyResultsAPI.
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Verifying IIS Settings
Verifying IIS Settings

You need to verify the following IIS settings:
 UploadReadAheadSize setting
 Preload Enabled setting is set to true

 To verify your UploadReadAheadSize setting:

1 Open IIS Manager.
2 In the Connections pane, select Sites > Default Web Site > CertifyAPI.
3 In the Management section, double-click Configuration Editor.

The Configuration Editor opens.

4 From the Section drop-down list, select serverRuntime.
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Verifying IIS Settings
5 Verify that the uploadReadAheadSize value is set to 2147483647.

6 Close the Configuration Editor after you have verified the value.

 To verify the Preload Enabled setting:

1 Open IIS Manager.
2 In the Connections pane, select Sites > Default Web Site > CertifyAPI.
3 In the Actions pane, select Advanced Settings.

The Advanced Settings dialog box opens.

4 Verify that the Preload Enabled setting is set to True.
5 Click OK.
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Troubleshooting
Troubleshooting

If you are having trouble with Worksoft Certify Services, open your Worksoft Certify API URL in a browser to 
verify that your meta data appears: 
https://<servername>/CertifyAPI/odata/$metadata

Configuring a Custom Web Site

If your company prefers to create a custom web sites uses web sites requiring a Secure Socket Layer (SSL), 
you will need to create a custom web site before installing Worksoft Certify API.
When you create your custom web site, you will need to consider the following:
 Will your web site use a DNS entry in the host header for the service? 

If not, then the web site will need to run on a different port number than the default port 80.
Example URL: http://<servername>:port/certifyapi

 Will the custom web site use SSL?
If so, a binding will need to be created for SSL, and a Certification Authority (CA) certificate will need to be 
installed on the server.

Application Pool Settings

You must set up an application pool with the following Advanced Settings properties:

To update these properties, right-click on the application pool and select Advanced Settings.

Setting Group Setting Value

General .NET Framework Version v4.0

General Start Mode AlwaysRunning

Process Model Identity LocalSystem
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Using Windows Authorization
Using Windows Authorization

If you want to use Windows authorization for Worksoft Certify Services, you will need to do some additional 
configuration.
To configure Windows authorization, complete the following:
 Update the Web.config file
 Set up a service account
 Enable Windows Authentication in IIS
 Configure application pool setting
 Configure SQL Server access

 To update the Web.config file:

1 Open the following directory:
C:\Program Files(x86)\Worksoft\Certify Services\Certify Web API

2 Open the Web.config file in a text editor. 
3 In the update system.web section, you need to set the following:

• authentication mode = Windows
• identify impersonate = false
See example below:
<system.web>

…….

<authentication mode="Windows"/>

<identity impersonate="false"/>

</system.web>
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Using Windows Authorization
 To set up a Service account for Certify Services:

You must create a Service account to execute API requests. Example: CertifyTester1\worksoft0
After installing Certify Services, log on to Certify API Server and provide Full control to the Certify Web API 
directory above the Service account as shown below.

 To enable Windows Authentication in IIS

1 From the Start menu, select Control Panel > Programs and Features.
The Programs and Features window opens.

2 Click Turn Windows features on or off.
The Windows Features dialog box opens.

3 In the Features list, expand Internet Information Services > World Wide Web Services.
4 Select Add Roles and Features.

The Add Roles and Features Wizard opens.
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Using Windows Authorization
5 Click Next until come to the Server Roles page.

6 Expand the Web Server IIS role.
7 Under Security, select the Windows Authentication option.
8 Click Next until the Install option is enabled.
9 Click Install to complete the configuration.
10 Open the IIS Manager.
11 Click Authentication. 
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Using Windows Authorization
12 Enable Windows Authentication and disable all other Authentications.

 To create a custom account application pool setting:

1 Select Application Pools > CertifyAPI.

2 In the Edit Application Pool section, select Advanced Settings.

3 Select Identity from the list.
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Using Windows Authorization
The Application Pool Identity dialog box opens.

4 Select Custom account.
5 Click Set.

The Set Credentials dialog box opens.
6 Enter the Service account user name and password.
7 Click OK.
8 In the Set Credentials dialog box, click OK.
9 In the Advanced Settings dialog box, click OK.

     To configure SQL Server access:

Your database administrator will need to add the Service account to Logins under Security in order to provide 
access to Certify database.
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Appendix A Worksoft Certify Firewall Port Settings

For Microsoft SQL Server, Certify uses the default port and protocol specified by the manufacturer. To permit 
Certify to work through a firewall, you must open the default TCP/IP port 1433. For more information, go to 
the following web site: http://support.microsoft.com/kb/287932 

Specifying a SQL Server Port Number for Your Database

If TCP/IP port 1433 is already being used by another application in your network or if it is restricted in your 
network environment due to security constraints, Microsoft provides a way to change this port number. For 
information on changing the default SQL Server port on the server itself, go to the following web site: 
http://support.microsoft.com/kb/823938.
After you change your port number, you will need to modify your Worksoft.Certify.exe.config file with this new 
port number setting. 

 To modify the Worksoft.Certify.exe.config file to specify a different database 
server port number: 

1 In the C:\Program Files\Worksoft\Certify\Client directory, open the 
Worksoft.Certify.exe.config file in a text editor, such as Notepad. 

2 Scroll down to the <appSettings> section and locate the line containing: 
<add key = "DATABASESERVER", value = "{server name}" /> 

3 Modify the value to specify the new port number by including a comma and the port number after the 
server name: 
<add key="DATABASESERVER" value="{server name},{port number}" /> 
EXAMPLE: 
To specify that Certify connects to the SQL Server via port 1434, you would use: 
<add key="DATABASESERVER" value="localhost,1434" />

http://support.microsoft.com/kb/823938
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Appendix B Worksoft Certify Silent Installation

Silent Install

To run Worksoft Certify installation silently, run the installer from the command line and add /s option to the 
executable: 
CertifySetup.exe /s

Installation Log File

The default installation log is located at %userprofile% of the user who installed Worksoft Certify. If you 
want to override the install log file location, enter the following string to provide an override for install log file 
location:
CertifySetup.exe /s /l=C:\temp\CertifyInstalllog.txt

Silent Uninstall

To uninstall Worksoft Certify silently, run the installer from the command line and enter the following string:
CertifySetup.exe /s MODIFY=FALSE REMOVE=TRUE UNINSTALL=YES

Certify Services

Silent Install

To run Certify Services installation silently, run the installer from the command line and add /s option to the 
executable: 
CertifyServices.exe /s

To install specific component:
For Certify Web API:
CertifyServices.exe /s certifyapi=true

For Certify Results API:
CertifyServices.exe /s resultsapi=true

For Certify Results API with Worksoft Portal:
CertifyServices.exe /s Portal_URL=http://servername/portalsuite
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Installation Log File
Installation Log File

The default installation log is located at %userprofile% of the user who installed Certify Services. If you 
want to override the install log file location, enter the following string to provide an override for install log file 
location:
CertifyServices.exe /s /l=C:\temp\CertifyServicesInstalllog.txt

Silent Uninstall

To uninstall Certify Services silently, run the installer from the command line and enter the following string:
CertifyServices.exe /s MODIFY=FALSE REMOVE=TRUE

Both components are removed.
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Appendix C Deploying Worksoft Certify Client Updates

You are able to deploy Worksoft Certify updates by creating a master desktop image.
Some IT organizations create a master desktop image of a user’s machine that has a Worksoft Certify client 
installed. The master desktop image should be considered as a single client machine.
You must start the Certify client at least once for the new patch package to deploy. If you do not start the 
Certify client, then the files will not be placed in the correct directories and any DLL files will not be registered.



Appendix D Configuring Emulators for the Mainframe 
Interface

The following emulators are supported for use with the Mainframe interface:
 NetManage Rumba® Office
 IBM Personal Communications®

 AttachmateWRQ® EXTRA!™ X-treme
 Rocket BlueZone® Terminal Emulator
 Jolly Giant Software QWS3270 Secure™

 IBM Aviva for Desktops™

Configuring RUMBA

You must have RUMBA installed prior to performing these steps.

 To configure a RUMBA emulator session:

1 Click Start > All Programs > RUMBA > Mainframe Display.
The RUMBA Mainframe window appears. 

2 Select Options > API. 
The API Options dialog box appears. 

3 In the Session Short Name field, select A in the drop-down list. 
4 Click the Configuration tab. 
5 Click the toggle button next to Classic HLLAPI data structure to select it. 
6 Click OK. 

The API dialog box closes. 
7 Select Connection > Configure. 

The Connection Configuration dialog box is displayed. 
8 On the General tab, click the toggle box next to AutoConnect to select it. 
9 In the Installed Interfaces section, select TN3270. 
10 Click the TN3270 tab. 
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Configuring RUMBA
11 Click Insert. 
12 Type a valid host name or IP address for the mainframe system being tested.
13 Click Connect.
14 Click OK. 

The RUMBA Mainframe Display returns with the connection made.
15 Select File > Save As. 
16 In the File Name field, type a name for the Rumba configuration file. 
17 Click Save.

The configuration is saved, and it will be recalled every time you open the configured session. 
18 Create a Desktop shortcut to this session.

 To configure Certify Screen Scraper:

Worksoft Certify’ s Screen Scraper application must be configured for your specific emulator in order to 
connect and map fields within a Mainframe session.
1 Contact Worksoft Customer Support and ask for a tdbg5.ocx file.
2 Copy the tdbg5.ocx file and paste into this directory:

C:\windows\syswow64

3 As an administrator, open a Command Prompt window and execute the following:
Execute: cd c:\windows\syswow64
Execute:  regsvr32 /u c:\windows\syswow64\tdbg5.ocx
Execute:  regsvr32 c:\windows\syswow64\tdbg5.ocx

4 Open the Screenscraper.xml file in a text editor of your choice. This file is located in the following 
directory: 
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe

5 In the Screenscraper.xml file, edit the bolded text below by adding one of the supported emulators in 
which you plan to use.

<EMULATORS>

<DEFAULT name="Rumba"></DEFAULT>
<EMULATOR name="Rumba">

<DLLNAME>WhllApi.Dll</DLLNAME>
<DLLPATH>C:\Program Files (x86)\Micro Focus\RUMBA\System</DLLPATH>
<SESSION>A</SESSION>
<CONFIGFILE></CONFIGFILE>
<REGKEY></REGKEY>
<REGPATH></REGPATH>
<KNOWNDLLNAME></KNOWNDLLNAME>
<KNOWNREGPATH></KNOWNREGPATH>
<KNOWNREGKEY></KNOWNREGKEY>

</EMULATOR>
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6 Verify that the session name is always set as A.
7 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
8 Once the steps above have been completed, shut down your emulator.
9 Verify that the Screen Scraper is shut down.
10 Relaunch both the emulator and Screen Scraper to test your connection.

If the connection is successful, the Learn button is enabled and the Connect button toggles to 
Disconnect.

Configuring IBM Personal Communications

You must have IBM Personal Communications® (IBM PCOM) installed prior to performing these steps.

 To configure a PCOM emulator session:

1 Click Start > All Programs > IBM Personal Communications > Start or Configure Sessions. 
The IBM Personal Communications Session Manager dialog box appears. 

2 Click New Session. 
The Customize Communications dialog appears. 

3 In the Type of Host field, select zSeries. 
4 In the Interface field, select LAN. 
5 In the Attachment field, select Telnet3270. 
6 Click Link Parameters. 
7 In the IP Address for Primary Type field, type a valid host name or IP address. 
8 Select the Auto Reconnect toggle button. 
9 Click OK. 
10 On the Customize Communications window, click OK. 
11 From the Edit > Preferences menu, select API. 
12 Verify that the DDE/EHLLAPI button is selected. 
13 Click OK. 
14 Click Save and save the file as Session A. 

The configurations are saved, and they are recalled every time you open the configured session. 
15 Create a Desktop shortcut to this session.
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 To configure Certify Screen Scraper:

Worksoft Certify’ s Screen Scraper application must be configured for your specific emulator in order to 
connect and map fields within a Mainframe session.
1 Contact Worksoft Customer Support and ask for a tdbg5.ocx file.
2 Copy the tdbg5.ocx file and paste into this directory:

C:\windows\syswow64

3 As an administrator, open a Command Prompt window and execute the following:
Execute: cd c:\windows\syswow64
Execute:  regsvr32 /u c:\windows\syswow64\tdbg5.ocx
Execute:  regsvr32 c:\windows\syswow64\tdbg5.ocx

4 Open the Screenscraper.xml file in a text editor of your choice. This file is located in the following 
directory: 
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe

5 In the Screenscraper.xml file, edit the bolded text below by adding one of the supported emulators in 
which you plan to use.

<EMULATORS>

<DEFAULT name="IBM Pcom"></DEFAULT>
<EMULATOR name="IBM Pcom">

<DLLNAME>WHLAPI32.dll</DLLNAME>
<DLLPATH></DLLPATH>
<SESSION>A</SESSION>
<CONFIGFILE></CONFIGFILE>
<REGKEY></REGKEY>
<REGPATH></REGPATH>
<KNOWNDLLNAME></KNOWNDLLNAME>
<KNOWNREGPATH></KNOWNREGPATH>
<KNOWNREGKEY></KNOWNREGKEY>

</EMULATOR>

6 Verify that the session name is always set as A.
7 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
8 Once the steps above have been completed, shut down your emulator.
9 Verify that the Screen Scraper is shut down.
10 Relaunch both the emulator and Screen Scraper to test your connection.

If the connection is successful, the Learn button is enabled and the Connect button toggles to 
Disconnect.
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Configuring Attachmate EXTRA!

To learn and test Mainframe applications using Attachmate EXTRA! X-treme, you need to configure an 
emulator session. Before you perform these steps, Attachmate EXTRA! needs to be installed.
When using the Mainframe interface, the Certify directory under C:\Program Files\Worksoft should be 
writable. For security reasons, if you cannot grant users Write permissions to the Certify directory, then you will 
need to save the Attachmate Extra! *.edp session on a writable shared network drive. 

 To configure a new EXTRA! X-treme emulator session:

1 Click Start > All Programs > Attachmate EXTRA! X-treme > Attachmate EXTRA! X-treme. 
The EXTRA! X-treme Session Manager dialog box appears. 

2 Select the Creating a New Session option.
3 Click OK. 
4 Select IBM Mainframe as the host type.
5 Click Next. 
6 Select 3270 Display for the type session.
7 Click Next. 
8 Select TN3270 for the type of connection.
9 Click Next. 
10 On the General tab, click Add. 
11 Type the Host Name or IP Address and click OK. 
12 Click Next. 
13 Select None for the type of file transfer to use.
14 Click Next. 
15 Click Finish. 

The new session window appears. 
16 From the Options menu, select Global Preferences. 
17 Click the Advanced tab 
18 Select A for the session short name. 
19 Click Browse and select the name of the session you are currently configuring from the list of session 

(e.g., Session1). 
20 Click Open. 
21 Click OK to save the session. 
22 Create a Desktop shortcut to this session.
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 To configure Certify Screen Scraper:

Worksoft Certify’ s Screen Scraper application must be configured for your specific emulator in order to 
connect and map fields within a Mainframe session.
1 Contact Worksoft Customer Support and ask for a tdbg5.ocx file.
2 Copy the tdbg5.ocx file and paste into this directory:

C:\windows\syswow64

3 As an administrator, open a Command Prompt window and execute the following:
Execute: cd c:\windows\syswow64
Execute:  regsvr32 /u c:\windows\syswow64\tdbg5.ocx
Execute:  regsvr32 c:\windows\syswow64\tdbg5.ocx

4 Open the Screenscraper.xml file in a text editor of your choice. This file is located in the following 
directory: 
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe

5 In the Screenscraper.xml file, edit the bolded text below by adding one of the supported emulators in 
which you plan to use.

<EMULATORS>

<DEFAULT name="Attachmate Extra"></DEFAULT>
<EMULATOR name="Attachmate Extra">

<DLLNAME>WHLLAPI.DLL</DLLNAME>
<DLLPATH></DLLPATH>
<SESSION>A</SESSION>
<CONFIGFILE></CONFIGFILE>
<REGKEY></REGKEY>
<REGPATH></REGPATH>
<KNOWNDLLNAME></KNOWNDLLNAME>
<KNOWNREGPATH></KNOWNREGPATH>
<KNOWNREGKEY></KNOWNREGKEY>

</EMULATOR>

6 Verify that the session name is always set as A.
7 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
8 Once the steps above have been completed, shut down your emulator.
9 Verify that the Screen Scraper is shut down.
10 Relaunch both the emulator and Screen Scraper to test your connection.

If the connection is successful, the Learn button is enabled and the Connect button toggles to 
Disconnect.
86 Worksoft Certify Installation Guide



Configuring Rocket BlueZone Terminal Emulator
Configuring Rocket BlueZone Terminal Emulator

You must have BlueZone installed prior to these steps.

 To configure BlueZone:

1 On your desktop, double-click the BlueZone Session Manager icon.
The BlueZone Session Manager opens.

2 From the BlueZone Session Manager menu, select Session > New Mainframe Display or select 
Start > All Programs > BlueZone 6.x > Mainframe Display on your desktop.
The Define New Connection dialog box appears.
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3 In the Connection Name field, type in the name you want for this connection.
4 In the Host Address field, type in the IP address of the mainframe host in which you want to connect.
5 Click OK.

The TN3270E Properties dialog box appears.

6 Click OK.
If the connection to the mainframe host was successful, the BlueZone Mainframe screen appears.
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7 From the BlueZone Mainframe menu, select Options > API.
The Settings Viewer - API Properties dialog box appears.

8 In the Dynamic Data Exchange section, select the Enable DDE Server Interface option.
9 Click OK.
10 In the BlueZone Mainframe menu, select File > Save to save this session configuration to the location 

of your choice.

 To configure Certify Screen Scraper:

Worksoft Certify’ s Screen Scraper application must be configured for your specific emulator in order to 
connect and map fields within a Mainframe session.
1 Contact Worksoft Customer Support and ask for a tdbg5.ocx file.
2 Copy the tdbg5.ocx file and paste into this directory:

C:\windows\syswow64

3 As an administrator, open a Command Prompt window and execute the following:
Execute: cd c:\windows\syswow64
Execute:  regsvr32 /u c:\windows\syswow64\tdbg5.ocx
Execute:  regsvr32 c:\windows\syswow64\tdbg5.ocx

4 Open the Screenscraper.xml file in a text editor of your choice. This file is located in the following 
directory: 
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe
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5 In the Screenscraper.xml file, edit the bolded text below by adding one of the supported emulators in 
which you plan to use.

<EMULATORS>

<DEFAULT name="BlueZone"></DEFAULT>
<EMULATOR name="BlueZone">

<DLLNAME>WHLAPI32.dll</DLLNAME>
<DLLPATH>C:\Program Files (x86)\BlueZone\6.1</DLLPATH>
<SESSION>A</SESSION>
<CONFIGFILE></CONFIGFILE>
<REGKEY></REGKEY>
<REGPATH></REGPATH>
<KNOWNDLLNAME></KNOWNDLLNAME>
<KNOWNREGPATH></KNOWNREGPATH>
<KNOWNREGKEY></KNOWNREGKEY>

</EMULATOR>

6 Verify that the session name is always set as A.
7 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
8 Once the steps above have been completed, shut down your emulator.
9 Verify that the Screen Scraper is shut down.
10 Relaunch both the emulator and Screen Scraper to test your connection.

If the connection is successful, the Learn button is enabled and the Connect button toggles to 
Disconnect.

Configuring QWS3270 Secure

This procedure is intended specifically for Jolly Giant Software QWS3270 Secure™ v4.8. You must have 
QWS3270 Secure installed prior to these steps.
To configure your QWS3270 Secure emulator, you will do the following tasks:
 Configure a QWS3270 emulator session
 Edit the ScreenScraper.xml and ScrScr.ini files
 Set the Terminal Emulator in Mainframe Learn (ScreenScraper) and verify the configuration

 To configure QWS3270 Secure emulator session:

1 Click Start > All Programs > QWS3270 Secure> QWS3270s > Connect.
QWS3270 Secure emulator opens.

2 From the QWS3270 menu, select Edit > Options.
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The Session Options dialog box opens.

3 In the right Navigation pane, select Connection > Host Settings.
4 In the Host Settings section, replace SESSIONA with A in the DDE Topic field.
5 In the right Navigation pane, select Connection.
6 In the Connection section, select A in the HLLAPI Session ID drop-down list.

7 Click OK.
 Your session is now configured.
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 To configure Certify Screen Scraper:

Worksoft Certify’s Screen Scraper application must be configured for your specific emulator in order to connect 
and map fields within a Mainframe session.
1 Contact Worksoft Customer Support and ask for a tdbg5.ocx file.
2 Copy the tdbg5.ocx file and paste into this directory:

C:\windows\syswow64

3 As an administrator, open a Command Prompt window and execute the following:
Execute: cd c:\windows\syswow64
Execute:  regsvr32 /u c:\windows\syswow64\tdbg5.ocx
Execute:  regsvr32 c:\windows\syswow64\tdbg5.ocx

4 Open the Screenscraper.xml file in a text editor of your choice. This file is located in the following 
directory: 
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe

5 In the Screenscraper.xml file, edit the bolded text below by adding one of the supported emulators in 
which you plan to use.

<EMULATORS>

<DEFAULT name="QWS3270"></DEFAULT>
<EMULATOR name="QWS3270">

<DLLNAME>WHLLAPI.DLL</DLLNAME>
<DLLPATH>C:\Program Files (x86)\QWS3270 Secure</DLLPATH>
<SESSION>A</SESSION>
<CONFIGFILE></CONFIGFILE>
<REGKEY></REGKEY>
<REGPATH></REGPATH>
<KNOWNDLLNAME>WHLLAPI.DLL</KNOWNDLLNAME>
<KNOWNREGPATH></KNOWNREGPATH>
<KNOWNREGKEY></KNOWNREGKEY>

</EMULATOR>

6 Verify that the session name is always set as A.
7 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
8 Once the steps above have been completed, shut down your emulator.
9 Verify that the Screen Scraper is shut down.
10 Relaunch both the emulator and Screen Scraper to test your connection.

If the connection is successful, the Learn button is enabled and the Connect button toggles to 
Disconnect.

11 Open the ScrScr.ini file in a text editor. This file is located in the following directory:
C:\Program Files (x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe

12 In the EmChecked field, update the value:
EmChecked=QWS3270

13 Save your changes.
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Configuring IBM Aviva for Desktop

You must have IBM Aviva for Desktop (32 bit version) installed prior to performing these steps.

 To configure a Aviva emulator session:

1 Launch the Aviva Session Manager from Start > All Programs > Aviva for Desktops > Aviva 
Session Manager.
The Aviva Session Manger window appears. 

2 Select the Creating a New Session option and click OK. 
3 In the respective fields, type in the name and description of the new session.
4 In the Session Type drop-down list, select 3270.
5 Click Next.
6 On the next page, click Next again.
7 For Setup, select Express Setup.
8 In the Connection Type field, select TN3270.
9 Click Next.
10 For the host session that you would like to connect, enter the IP address.
11 For TCP port, select default port 23.
12 Click Next.
13 On the next page, click Next again.
14 Click Finish to close the wizard.
15 From the Aviva Session Manager menu, select Session > Properties.

The Properties dialog box appears.
16 Click the Destination tab. 
17 Select the Automatically connect when session is started option.
18 Click the Automation tab.
19 Cancel the Choose first available short name option.
20 In the Short Name field, type A in the drop-down list. 
21 Click the Terminal tab.
22 In Screen Size section, select Model 2 from the Screen Model drop-down list.
23 Click OK.
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Interface

With Certify LiveTouch™, you are able to learn objects while adding steps to your process and save the objects 
to a specific application version with the Certify LT interface. You will be able to use these new learned objects 
in other processes because these objects are saved in your Certify database.
When using Certify LiveTouch with the Mainframe LT interface, you must use the Aviva for Desktops™ emulator 
(32-bit only) to create Certify steps.
After you have created your steps with Certify LiveTouch, then you can use the following emulators for 
execution:
 IBM Aviva for Desktops™ v16
 IBM Personal Communications®

 Rocket BlueZone® Terminal Emulator
 Jolly Giant Software QWS3270 Secure™

Configuring IBM Aviva for LiveTouch and Execution

You must have IBM Aviva for Desktop (32 bit version) installed prior to performing these steps.

 To configure a Aviva emulator session:

1 Launch the Aviva Session Manager from Start > All Programs > Aviva for Desktops > Aviva 
Session Manager.
The Aviva Session Manger window appears. 

2 Select the Creating a New Session option and click OK. 
3 In the respective fields, type in the name and description of the new session.
4 In the Session Type drop-down list, select 3270.
5 Click Next.
6 On the next page, click Next again.
7 For Setup, select Express Setup.
8 In the Connection Type field, select TN3270.
9 Click Next.
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10 For the host session that you would like to connect, enter the IP address.
11 For TCP port, select default port 23.
12 Click Next.
13 On the next page, click Next again.
14 Click Finish to close the wizard.
15 From the Aviva Session Manager menu, select Session > Properties.

The Properties dialog box appears.
16 Click the Destination tab. 
17 Select the Automatically connect when session is started option.
18 Click the Automation tab.
19 Cancel the Choose first available short name option.
20 In the Short Name field, type A in the drop-down list. 
21 Click the Terminal tab.
22 In Screen Size section, select Model 2 from the Screen Model drop-down list.
23 Click OK.

Configuring Certify for Execution

You must apply edits to the Mainframe LT configuration file for execution and using Certify LiveTouch.

 To configure Certify for execution:

1 Open the following directory:
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe-LT

2 Open the EmulatorConfiguration.xml file in a text editor. 
3 In the EmulatorConfiguration.xml file, edit the text by adding one of the supported emulators in which 

you plan to use.
<EMULATORS>

<DEFAULT name="Aviva"></DEFAULT>

<EMULATOR name="Aviva">

<DLLNAME>WhllApi.Dll</DLLNAME>

<DLLPATH> C:\Program Files (x86)\Aviva Solutions\AFD</DLLPATH>

<SESSION>A</SESSION>

</EMULATOR>

</EMULATOR>

4 Verify that the session name is always set as A.
5 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
6 Save your changes to the configuration file.
7 Once the steps above have been completed, shut down your emulator.
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Configuring IBM Personal Communications for Execution

You must have IBM Personal Communications® (IBM PCOM) installed prior to performing these steps.
After you install Host On-Demand, you will need to do the following to complete configuration:
 Configure an IBM Host On-Demand session
 Configure Certify for execution

 To configure a PCOM emulator session:

1 Click Start > All Programs > IBM Personal Communications > Start or Configure Sessions.
The IBM Personal Communications Session Manager dialog box appears.

2 Click New Session. 
The Customize Communications dialog appears. 

3 In the Type of Host field, select zSeries.
4 In the Interface field, select LAN.
5 In the Attachment field, select Telnet3270.
6 Click Link Parameters.
7 In the IP Address for Primary Type field, type a valid host name or IP address.
8 Select the Auto Reconnect toggle button.
9 Click OK.
10 On the Customize Communications window, click OK. 
11 From the Edit > Preferences menu, select API. 
12 Verify that the DDE/EHLLAPI button is selected. 
13 Click OK. 
14 Click Save and save the file as Session A. 

The configurations are saved, and they are recalled every time you open the configured session.
15 Create a Desktop shortcut to this session.
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Configuring Certify for Execution

You must apply edits to the Mainframe LT configuration file for execution and using Certify LiveTouch.

 To configure Certify for execution:

1 Open the following directory:
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe-LT

2 Open the EmulatorConfiguration.xml file in a text editor. 
3 In the EmulatorConfiguration.xml file, edit the text by adding one of the supported emulators in which 

you plan to use.
<EMULATORS>

<DEFAULT name="IBM Pcom"></DEFAULT>

<EMULATOR name="IBM Pcom">

<DLLNAME>WhllApi.Dll</DLLNAME>

<DLLPATH>…</DLLPATH>

<SESSION>A</SESSION>

</EMULATOR>

</EMULATOR>

4 Verify that the session name is always set as A.
5 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
6 Save your changes to the configuration file.
7 Once the steps above have been completed, shut down your emulator.
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Configuring Rocket BlueZone Terminal Emulator for Execution

You must have BlueZone installed prior to these steps.

 To configure BlueZone:

1 On your desktop, double-click the BlueZone Session Manager icon.
The BlueZone Session Manager opens.

2 From the BlueZone Session Manager menu, select Session > New Mainframe Display or select 
Start > All Programs > BlueZone x.x > Mainframe Display on your desktop.
The Define New Connection dialog box appears.
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3 In the Connection Name field, type in the name you want for this connection.
4 In the Host Address field, type in the IP address of the mainframe host in which you want to connect.
5 Click OK.

The TN3270E Properties dialog box appears.

6 Click OK.
If the connection to the mainframe host was successful, the BlueZone Mainframe screen appears.
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7 From the BlueZone Mainframe menu, select Options > API.
The Settings Viewer - API Properties dialog box appears.

8 In the Dynamic Data Exchange section, select the Enable DDE Server Interface option.
9 Click OK.
10 In the BlueZone Mainframe menu, select File > Save to save this session configuration to the location 

of your choice.

Configuring Certify for Execution

You must apply edits to the Mainframe LT configuration file for execution and using Certify LiveTouch.

 To configure Certify for execution:

1 Open the following directory:
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe-LT

2 Open the EmulatorConfiguration.xml file in a text editor. 
3 In the EmulatorConfiguration.xml file, edit the text by adding one of the supported emulators in which 

you plan to use.
<EMULATORS>

<DEFAULT name="Blue Zone"></DEFAULT>
<EMULATOR name="Blue Zone">

<DLLNAME>WHLLAPI32.Dll</DLLNAME>
<DLLPATH>C:\Program Files (x86)\BlueZone\7.1</DLLPATH>
<SESSION>A</SESSION>

</EMULATOR>
</EMULATOR>
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4 Verify that the session name is always set as A.
5 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
6 Save your changes to the configuration file.
7 Once the steps above have been completed, shut down your emulator.

Configuring QWS3270 Secure for Execution

This procedure is intended specifically for Jolly Giant Software QWS3270 Secure™ v4.8. You must have 
QWS3270 Secure installed prior to these steps.

 To configure QWS3270 Secure emulator session:

1 Click Start > All Programs > QWS3270 Secure> QWS3270s > Connect.
QWS3270 Secure emulator opens.

2 From the QWS3270 menu, select Edit > Options.
The Session Options dialog box opens.

3 In the right Navigation pane, select Connection > Host Settings.
4 In the Host Settings section, replace SESSIONA with A in the DDE Topic field.
5 In the right Navigation pane, select Connection.
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6 In the Connection section, select A in the HLLAPI Session ID drop-down list.

7 Click OK.
 Your session is now configured.

Configuring Certify for Execution

You must apply edits to the Mainframe LT configuration file for execution and using Certify LiveTouch.

 To configure Certify for execution:

1 Open the following directory:
C:\Program Files(x86)\Worksoft\Certify\Interface Client\Worksoft\Mainframe-LT

2 Open the EmulatorConfiguration.xml file in a text editor. 
3 In the EmulatorConfiguration.xml file, edit the text by adding one of the supported emulators in which 

you plan to use.
<EMULATORS>

<DEFAULT name="QWS3270 "></DEFAULT>

<EMULATOR name="QWS3270">

<DLLNAME>WHLLAPI.Dll</DLLNAME>

<DLLPATH>C:\Program Files (x86)\QWS3270 Secure</DLLPATH>

<SESSION>A</SESSION>

</EMULATOR>

</EMULATOR>

4 Verify that the session name is always set as A.
5 Verify that the emulator is configured to always use HLLAPI. If there is an option to enable HLLAPI 

during start up, select it.
6 Save your changes to the configuration file.
7 Once the steps above have been completed, shut down your emulator.
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Appendix F Configuring Java Runtime Environment

Installing the Java Interface JAR files

If you install the Certify client on a computer that does not have the Java Runtime Environment (JRE) installed, 
the Java Interface JAR files will not install during installation, and the Java interface will not work. You will 
need to install the supported version of the JRE, and then install the Java Interface JAR files into the 
JRE directory using the Java Interface's JAR Installer tool.
You will also need to run the Java Interface's JAR Installer tool if your application uses its own JRE copy or 
uses a different JRE version other than the one registered on your computer.
To run the JAR installer, you need to be an administrator on the local machine. You can open the installer from 
the Start menu on your desktop or from the following directory:
 C:\Program Files (x86)\Worksoft\Certify\Interface Client\Worksoft\wsTest\Java\Installer

 To install the Java Interface JAR files with the installed JRE:

1 From the Start menu on your desktop, select All Programs > Worksoft > JAR Installer.
The Certify Java Installer opens.

2 Click Find Installed JREs.
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In the Select Destination Java Runtime Environments (JREs) field, the available JREs are listed.

3 From the list, select a JRE.
4 Click Next.

The Select Interfaces to Install field opens.
5 Select Java.
6 Click Install.

The Java Interface JAR files are installed in the selected folder.
7 When the Confirmation message appears, click OK.
8 Close the Certify Java Installer.

 To install the Java Interface JAR files to an application’s JRE:

1 Open the Java application.
2 From the Start menu on your desktop, select All Programs > Worksoft > JAR Installer.

The Certify Java Installer opens.
3 Click Browse for JREs to browse to the JRE directory where you want to install the Java Interface 

JAR files.
4 Select an application and click OK. To select multiple applications, use the <Shift> key.

In the Select Destination Java Runtime Environments (JREs) field, the JREs used by the selected 
application are listed.

5 From the list, select a JRE.
6 Click Install.

The Java Interface JAR files are installed in the selected folder.
7 When the Confirmation message appears, click OK.
8 Close the Certify Java Installer.
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 To install the Java Interface JAR files by browsing to the JRE directory:

1 Open the Java application.
2 From the Start menu on your desktop, select All Programs > Worksoft > JAR Installer.

The Certify Java Installer opens.
3 Click Running JREs
4 Select an application and click OK. To select multiple applications, use the <Shift> key.

In the Select Destination Java Runtime Environments (JREs) field, the JREs used by the selected 
application are listed.

5 From the JREs list, select a JRE. To select multiple applications, use the <Shift> key.
6 Click Install.

The Java Interface JAR files are installed in the selected folder.
7 When the Confirmation message appears, click OK.
8 Close the Certify Java Installer.
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Appendix G Compressing Images in Your Database

In the Worksoft Certify v12.0.2112 release, step screenshots are stored in the database in a more efficient 
way. With this version, Certify compresses images without affecting the readability of the image content.
Duplicate images are only saved once in the database. By storing only one copy of an image, lower storage 
space is used, and performance degradation is prevented.
New tables are created to store images, and they are mapped to the test step results. The existing 
LogImageData rows are changed to LogFileStream rows after you have upgraded your database.
For existing customers, there is no change to the upgrade Certify database process if you have less than 
500,000 LogImageData rows. For information on upgrading your database, see Chapter 5 “Upgrading Your 
Worksoft Certify Client Version”.

Upgrading Your Database with over 500K LogImageData Rows

If you have over 500,000 LogImageData rows in your database, you need to use the upgrade and migration 
executables in the UpdateDatabase - Post Upgrade Migration directory.

 To upgrade your large database:

1 Locate the Apply.exe utilities within your Certify distribution package:
...\Worksoft Certify Site Prep\Site Prep\Database Scripts\UpdateDatabase - 
Post Upgrade Migration

2 Before you install the Certify upgrade on your production server, you need to test and verify the upgrade 
release. For more information, see “Testing the Worksoft Certify Upgrade Release” on page 31.

3 Use the Apply.exe tool in the 1. Upgrade directory to upgrade your database:
...\Worksoft Certify Site Prep\Site Prep\Database Scripts\UpdateDatabase - 
Post Upgrade Migration\1.Upgrade

4 After you have upgraded your database, use the Apply.exe tool in the 2. Migration directory:
...\Worksoft Certify Site Prep\Site Prep\Database Scripts\UpdateDatabase - 
Post Upgrade Migration\2. Migration.

After running the Post-Upgrade Migration scripts, screenshots can be viewed.
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